Intermittent issues with D&B Connect manage

Incident Report for D&B Connect

Resolved

All services have been fully restored as of 11:45pm EDT. Our services were partially unavailable due to an outage with our upstream infrastructure provider. Scheduled jobs were not impacted by these issues. We sincerely apologize for the disruption and are working with our provider to prevent similar incidents in the future.
Posted Oct 21, 2025 - 11:10 UTC

Monitoring

Services have been running as normal without error for the last 30 minutes. We will continue to monitor the services
Posted Oct 21, 2025 - 04:44 UTC

Update

Our engineering team is continuing to work on the issue and is working closely with our upstream providers to restore full functionality. We will provide the next update as soon as more information becomes available.
Posted Oct 21, 2025 - 03:36 UTC

Update

Our engineering team is continuing to investigate the issue and is working closely with our upstream providers to restore full functionality. Scheduled jobs are running. We will provide the next update as soon as more information becomes available.
Posted Oct 21, 2025 - 02:51 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 20:34 UTC

Investigating

We are currently experiencing intermittent issues with D&B Connect Manage due to upstream service interruptions related to the global AWS outages. Some users may encounter difficulties accessing the service or may experience degraded performance. We will provide updates as soon as we have more information
Posted Oct 20, 2025 - 20:32 UTC
This incident affected: Web Portal, Data Ingest, Data Pipelines, and Data Publish.